최근에 Windows 7 에서 julia 를 다시 설치하고 패키지 관련 명령어들을 사용을 해보니 다음과 같은 에러가 발생을 했습니다. 위 제목에도 표시를 했지만 발생한 에러는 다음과 같습니다.

ERROR: GitError(Code:ECERTIFICATE, Class:OS, user cancelled certificate check: )

이렇게 에러가 날 때는 구글링 하면 되죠 뭐… 검색을 해보니 해결 방법으로 아래 페이지가 나왔습니다.

https://support.microsoft.com/en-us/help/3140245/update-to-enable-tls-1-1-and-tls-1-2-as-a-default-secure-protocols-in

위 페이지에서 페이지를 조금만 내려 보시면 ~ 다음과 같이 Easy fix 라는 글자를 볼 수가 있습니다. Download 버튼을 눌러서 MicrosoftEasyFix51044.msi 파일을 다운로드 받아서 실행합니다. 이제 다 해결 됐습니다.

줄리아를 다시 실행하고 Pkg.update() 를 해 보니 정상적으로 동작을 하더군요.



책 보면서 cmake 따라 해 보다가

 

아래 문자와 같은 에러를 만났습니다.

 

 

CMAKE_CXX_COMPILER-NOTFOUND

 

 

책에 하라는 데로 똑같이 따라 했는데.. 저런 에러를 만나니 무지하게 당황 되더군요.

 

책에는 저런 에러 없었는데 말이죠. ㅋㅋ

 

그래서 구박사에 질문을 하니 역시.. 답변이 있더군요.

 

위 에러는 빌드 툴이 없어서 그런거라네요.

 

그래서 다음과 같은 터미널 명령어로 build-essential 을 설치해 줘야 한다는 군요.

 

 

sudo apt-get install build-essential -y

 

 

이후에는 cmake 가 정상적으로 되더군요.


+ Recent posts